Problems subscribing agent, Windows XP

Hi there,

I try to subscribe an agent on a Windows XP machine to our Shadowcontrol appliance but it seems that I ran out of luck and solutions.

Here is what I did so far:

1. Installed the agent as local admin via msiexec and tried to subscribe via stccmd. I've uploaded a picture of the error message as attachment.

2. Reinstalled the agent as user with elevated cmd shell. Same error message.

3. Reinstalled as user with PSEXEC system cmd shell. Same error message.

From the agent side I am able to connect to the ports 443, 5556, 8443 via telnet and to the local port 13579 and I could verify that all services are running.

Any help would be very nice!

Greetings

Bastian

AttachmentSize
error.png37.72 KB
Forums:

Comments

STC-JoshS

Which agent are you using?

Which agent are you using? The 4.0 endpoint doesn't support XP, you will need to use the 3.8

bastian235

I am using the legacy version

I am using the legacy version of the appliance and the agent. Should be  version 3.8.0, correct me if I'm wrong.
I read in the userguide that Windows XP is not supported since version 4.0.

STC-JoshS

Double check the version on

Double check the version on the installer. That looks like a python error that I would expect to see on a 4.0 install. I would also make sure that the XP machine is fully patched.

bastian235

Well, I used the agent

Well, I used the agent provided by the appliance itself. But I will download the agent from the storagecraft page and try again.
Should I run the agent and services as SYSTEM or local admin?

STC-JoshS

System should suffice.

System should suffice.

bastian235

I have double checked the

I have double checked the version of the agent and its 3.8.1128.0. The XP machine is up to date.
After I removed everything regarding shadowcontrol (leftover files and reg entries) I tried to reinstall the agent with system permissions.
Restartet the machine just to be sure ...still the same error message when I try to subscribe.

I played a bit with the stccmd.exe and I get errors, when I try to execute "stccmd.exe version" and "stccmd.exe settings". Error states that it cant connect to http://127.0.0.1:13579. Service is running, I can also see the open port with netstat and I am able to connect to it via telnet.

If I could I would just upgrade the machine to at least Win7 but its a Siemens SIMATIC Box with a production machine attached to it, so .....

 

STC-JoshS

I figured if it was still

I figured if it was still running XP at this point it would be something like that. Is the firewall on? Can we add an exception for that port to get through?

bastian235

The firewall is deactivated

The firewall is deactivated on this machine. Upgrading to Win7 is not an option due to the production machine attached to the box.  Why should I add an exception for a local port in the firewall? oO

 

STC-JoshS

Because Windows firewall,

Because Windows firewall, especially the older ones, does funny things. Its annecdotal but I've seen a turned off windows firewall still block communication unless we disabled the service. This wasn't with StorageCraft's products granted, but a former employer. On that off chance, is the firewall service still running? If it is, I would find a time where you can schedule some downtime for the system (may or may not be possible I understand) and access the system physically and disable the service. Don't do this remotely because I've also seen that take the system down (again, mostly with older windows) and require a reboot and I know how finicky attached computers are.

bastian235

Hi, so each of the mentioned

Hi, so each of the mentioned steps above were done at the machine directly because I have no remote access to them. Luckily this machine is the only one in production that is paused for some weeks. I was able to deactivate the whole firewall service today and tried to subscribe again. Same issue again ... So it seems like the error is not network related but something else. Do you have any other ideas? I really appreciate your help.

STC-JoshS

I think if you have a window

I think if you have a window it might be best for support to get involved so they can look at the subscription logs. Can you access the appliance from the machine that you are trying to subscribe?

STC-JoshS

Is there an ä in the name of

Is there an ä in the name of the system you are trying to subscribe or the appliance host?

JDDellGuy

Have you tried disabling the antivirus?

I've seen cases for various applications in which the antivirus software was blocking the connection.  Might be worth ensuring that is not running as a test.

 

Also, is it possible that another service may be using those ports?  If you uninstall ShadowControl, do those ports still respond?  If so, then another application may be conflicting with the use of those ports.

Terms and Conditions of Use - Privacy Policy - Cookies