The RPC server is unavailable - Windows 7 firewall
Article Number:
95
Problem:
Users are getting "The RPC server is unavailable" when trying to connect to a new node in the Management View.
Cause:
The Windows 7 firewall is blocking incoming DCOM packets.
Resolution:
Disable the firewall. Or, add an exception in the firewall.
Here are the steps to add a fire wall exception:
- In your search box type "wf.msc", this will open the Windows Firewall settings.
- On the tree in the left panel, click on "inbound rules".
- In the inbound rules find and enable the 2 rules named "Windows Management Instrumentation (DCOM-In)".
- On the tree in the left panel, right click on "inbound rules" and select "New Rule...".
- On the rule type, Select the "Program" radio button and hit "Next...".
- On the Program Page, Hit the "Browse...", navigate to C:\Program Files (x86)\StorageCraft\ShadowProtect", select "ShadowProtectSvc.exe". Click OK, and then Next
- On the Action Page, select the "Allow the connection" radio button (default setting). Click Next.
- On the Profile Page, select all of the check boxes. (default settings)
- On the Name Page, Type "ShadowProtect Service" in the name box.
- Click Finish to close the wizard.
Go back to the management view on the other machine, and attempt to connect.

